All systems operational

Some Central Desktop Workspaces are not loading Files and Discussions.

Resolved
Partial outage
Started 9 days ago Lasted 34 minutes

Affected

Website
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.