Central Desktop - Central Desktop System Outage – Incident details

All systems operational

Central Desktop System Outage

Resolved
Major outage
Started over 1 year agoLasted about 7 hours

Affected

Website

Major outage from 6:00 AM to 12:30 PM

Updates
  • Resolved
    Resolved

    We have identified the issue and confirmed that the system performance has been restored.

  • Investigating
    Investigating

    Users are receiving the following message: The site is not secure as it uses an Unsupported Protocol. We are currently researching.