All systems operational

Central Desktop System Outage

Resolved
Major outage
Started 11 months ago Lasted 19 minutes

Affected

Website
Updates
  • Resolved
    Resolved

    System has been restored. Processing may be a little slow initially as the system re-initializes all the systems.

  • Investigating
    Investigating

    We are currently investigating this incident.